Join our new community forum for support & discussion

Join Now

Home Support General HivePress Add blog post thumbnail

Add blog post thumbnail

  • Author
    Posts
  • kanazenda

    Hi, I would like know if it’s possible to add blog post thumbnail? The fonction “featured image” don’t appear on wordpress editor

    yevhen developer

    Please try disabling third-party plugins, I have just tested this locally and the Featured Image section appears in the Post Settings on the right.

    kanazenda

    I have disabling all extensions:
    elementor, elementkit, woocomerce, sendinblue, formidable form, GTranslate, iThemes Security, Loco Translate, Rank Math SEO, UpdraftPlus, WP-Optimize

    and all additional hivepress extensions!

    Nothing changes, I still don’t have the option to Add blog post thumbnail. I haven’t changed anything in the theme code except the code you provided me to put 4 columns in /submit-listing/category

    yevhen developer

    Please also try disabling HivePress to check if this issue is related to HivePress itself. Blog posts are implemented in WordPress by default, and if the Featured Image section is hidden when HivePress is disabled then it is related to WP installation.

    kanazenda

    Hello, I called a developer, he told me that it was a problem with the new wordpress Gutenberg editor, to solve the problem he had to reconfigure the classic editor. If that can help…

    ihor developer

    Thanks for posting the solution!

    sowickesited

    I’m using RentalHive theme and I noticed the same thing when trying to add featured images to my blog posts. I created a child theme with custom CSS and a custom functions.php file.

    Using the Gutenberg editor on the latest WordPress version 5.9.1, the Featured Image metabox doesn’t show up. You can’t add a Featured Image because the option just isn’t there. You can’t change the options in the top right corner to make it visible. It’s just gone.

    I installed the Classic Editor plugin that allows you to toggle back and forth between Gutenberg and Classic editors and I can see the Featured image metabox when using Classic but not Gutenberg. That’s an annoying bug and I don’t want to toggle back and forth on every post.

    After reading some help files, it does appear this has been an ongoing WordPress bug:
    https://stackoverflow.com/questions/67423437/featured-image-of-wordpress-doesnt-appear-in-admin

    I activated another theme, de-activated, flushed my cache, removed my functions.php file, reinstalled my child theme, added a blank index.php file to my theme directory. So I don’t know what ultimately helped.

    But I added add_theme_support( 'post-thumbnails' ); to my child theme functions.php file and that might have been the trick that worked.

    Now I can see the Featured Image metabox on wordpress posts while using the Gutenberg editor.

    ihor developer

    Thanks for the details, maybe Gutenberg disabled this by default and requires declaring a new support, will check this before the next update.

Viewing 8 posts - 1 through 8 (of 8 total)

New Reply

This forum has been archived and is no longer accepting new posts or replies. Please join our new community forum for support & discussion.