Join our new community forum for support & discussion

Join Now

Home Support Extensions Marketplace Buy now take me to the home page

Buy now take me to the home page

  • Author
    Posts
  • CurtisP

    Hi.

    When I click buy now on a listing, it takes me to the home page. I have no idea how to troubleshoot this if you guys can help out would be great.

    Thank you.

    yevhen developer

    If WooCommerce is installed, please also make sure that WooCommerce pages (Checkout, Cart, etc) were created. You can re-create these pages using a tool in WooCommerce/Status/Tools section. Also, please try refreshing permalinks in Settings/Permalinks

    egears

    I too am having the same issue. Please advise

    https://imgur.com/EAn1ec7
    From top to bottom:
    Blog
    Refunds and Return Policy
    Privacy Policy
    My account
    Home
    Listings
    Store
    Payment
    Shopping Cart

    Below I have provided a screenshot of the Permalink Settings page in wp-admin


    yevhen developer

    There may be different reasons for this redirect:

    1) Some booking details are missing (e.g. time slot duration, or other required booking details – you can check this by editing a listing).

    2) WooCommerce product is not generated for a listing. To check this, edit any listing and just re-save it (setting the price), then try to book it again.

    3) Some WooCommerce pages are missing (e.g. Checkout). You can try re-creating pages using a tool in WooCommerce/Status/Tools seciton.

    Hope this helps.

    egears

    Recommendation #2 Has solved the issue for me. I am redirected to the payment page. All I have left is to configure the payment gateway. Thank you yevhen!

Viewing 5 posts - 1 through 5 (of 5 total)

New Reply

This forum has been archived and is no longer accepting new posts or replies. Please join our new community forum for support & discussion.