Home Support Extensions Paid Listings Can’t increase listings limit for existing package

Can’t increase listings limit for existing package

  • Author
    Posts
  • bb-

    Hi!

    I think I’ve found a bug. I have an existing package with listings limit set to 10 (free, no linked woocommerce product). I’ve created an account which I’ve posted 10 listings with. Even though I increase the listing limit in the background for the free package the account can’t post more listing as the system says the listing limit is reached.

    Also, a small suggestion for the listing limit feature is to be able to set it to 0 for unlimited listings.

    Thanks for a great plugin!

    With best regards,

    bb

    bb-

    2. Also, if I have both free and pad packages and the user has bought a free package with let’s say 10 listings. When adding listing number two the user automatically “chooses” the free package even thogh there are other paid options for featuring a listing. Is this a bug or can I change this flow somehow?

    With best regards,

    bb

    ihor developer

    Thanks for your feedback,

    1. It’s not a bug – the limit is copied to the user’s account on the package selection, because the number of listings left may be different for each account. So after you select some package and change it’s limit globally, the limit for existing users who selected it before is not changed (it will be the next time they select this package, e.g. if it’s a premium one).

    2. Thanks, this is already on the roadmap.

    3. This is also planned, in the current version the package with a bigger limit is selected automatically.

    suncatcher

    Hi ihor,
    I’ve been working around with this paid listings plugin and experienced the same situation..
    Created packages as per the docs, with free package listing limit set to 1 and then created a test account, posted a listing and selected the free package, approved it. Then I set the listing limit to 2, tried to post another listing, but I was faced with LIMIT EXCEEDED for the free package.. I cleared all cookies, signed in, but the same issue remained.. I even was directed directly to the package page without having to select category and input listing details after I clicked “add listing”

    The Paid Listings plugin I’m using is the latest.

    Thank you ihor in advance.

    suncatcher

    Another question is:
    https://hivepress.io/support/topic/when-a-pending-listing-is-rejected-the-submit-limit-is-decreased-anyway/
    What I want is actually the opposite…
    A user is able to submit another listing is the previously submitted listing is rejected, means the limit is not released, the user won’t be able to submit new listings if I set the limit to 1.

    I just tested and trashed the user’s listing and deleted it, and the user is still unable to submit new listing. (might be because of the same issue I just replied to to this topic – increased the limit, but the free package still showed limit exceeded.)

    This actually IMO will shy away users. I hate spammers, but I want users with good intention to stay.

    Thanks again.

    ihor developer

    1. The listing limit is applied to the user account when some package is purchased or selected, then it depends on the usage. So if you change the limit for some package it’ll be applied for new purchases/selections only, please try registering as a new user and select a package.

    2. Yes, any listing submission or renewal is counted in the current version, I’ll try to find a better solution for this.

    RooninStark

    Hi ihor
    is it possible to clear the listing limit at database side? or do I have to recreate the user again?

    thanks

    ihor developer

    Yes, the listing packages are stored as hidden comments of “hp_listing_package” type in wp_comments table, with the corresponding user ID. The remaining number of listings is stored in the comment_karma field so you can try resetting it (or removing the comment).

    RooninStark

    Thanks for the answer.

    I delete hp_listing_package under the wp_comments table and the limits are gone. Had no problems creating a new service.

    There should be a button for this under each freelancer and or one at the freelancer settings for global reset.

    Or the better way is if reached to the end of the limit it should reset automatically.

    Cheers
    Best Regards
    Roonin

    ihor developer

    Thanks for your suggestion, yes, there should be some UI for managing the listing limit for each user separately (I added this to the roadmap).

    Timetraveller

    I posted earlier about this issue.

    If I post a free listing it works and gets submitted
    but then on the 2nd and subsequent listing submissions the featured package option does not get shown.

    If I delete the comment hp_listing_package it works, but only for the nest listing.
    If I have two packages FREE and FEATURED
    They should be shown as options to the user on each subsequent listing submission until the use up the quota.

    hp_listing_package comment I don’t think is the way to do it.

    Timetraveller

    This issue is a real road block for me.

    ihor developer

    Yes, the Select Package step will not appear until the current package limit is not exceeded. Please consider setting the free package limit to 1 so the Select Package step will appear on the next listing submission.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.