Join our new community forum for support & discussion

Join Now

Home Support Extensions Authentication facebook login doesn’t work

facebook login doesn’t work

  • Author
    Posts
  • aminetech

    Hi I’m currently using hivepress for my website and it is great, but I have encounter an issue with using a third party login. So I followed all the instructions to set up the third party login and everything is well setup until when you register yourself with facebook the window of facebook open so you can register with facebook and when you register yourself the window disappear and the login doesn’t work without showing an error message. And this problem occur only in a private window or in another browser

    So I tried to change the callback URL but this didn’t work and by the way i can login with google the only problem is facebook.

    thanks for help.

    aminetech

    you can try it yourself : https://oumarauto.com

    ihor developer

    Please make sure that you followed the same steps as in the tutorial and there are no additional restrictions for this API key, the extension returns this error:

    POST https://oumarauto.com/wp-json/hivepress/v1/users/authenticate/facebook 400

    This means that it tries to fetch the Facebook profile data via the API but the access is forbidden.

    aminetech

    Ok since you send me this message I did all this steps:
    1. I create a new facebook developpers account
    2. create a new app and followed exactly the instructions in this tutorial (https://hivepress.io/blog/add-social-login-to-wordpress-business-directory/)
    *after following the tutorial fecbook didn’t work so what I did is the following:
    3. I added a Valid OAuth Redirect URIs because facebook told me to do so
    4. I added the Login with the JavaScript SDK because they also told to do so
    5. and finally they told me to do to grant advanced access to public profile and I do it and it still doesn’t work and the console show the same thing
    “Failed to load resource: the server responded with a status of 400 ()”
    https://oumarauto.com/wp-json/hivepress/v1/users/authenticate/facebook”

    *Now at this point I’m blocked I don’t knoww if the problem is with facebook or hivepress thanks for help !

    ihor developer

    Please try disabling any third-party plugins/customizations first, in case if it’s a caching issue or conflict with some plugin. If this issue persists and it’s possible to test it you can send temporary WP access to support@hivepress.io and I’ll try to detect it.
    Also, we’ve just released a “pro” version of the Authentication, it has a different framework for the social login https://hivepress.io/extensions/social-login/ and more login methods (we’ll add more with every update). It has built-in buttons instead of JS buttons loaded via Facebook/Google so this may work if you decide to use it instead.

    aminetech

    I sended you a message !

    aminetech

    I tried to deactivate third party plugins but it still don’t work I send you an email. and for the pro version I’m not sure for now but maybe later when my website will generate money I’ll do it.

Viewing 7 posts - 1 through 7 (of 7 total)

New Reply

This forum has been archived and is no longer accepting new posts or replies. Please join our new community forum for support & discussion.