Join our new community forum for support & discussion

Join Now

Home Support Extensions Authentication Google Login Issue

Google Login Issue

  • Author
    Posts
  • darossi

    Hello

    Thanks again for this fantastic theme!

    I’m having an issue with Google Login – I’ve filled my client ID etc when when I enter my Google credentials, it says “one moment…” but then takes me to an empty sign in form.

    Am I missing a step?

    When I set up the client ID, I put the ‘Authorised JavaScript origins’ as my site. Do I also need to fill in the ‘Authorised redirect URIs’?

    Thanks

    ihor developer

    Please try disabling third-party plugins, this may be a caching issue. As far as I know, only “Authorized JavaScript Origins” is required, you don’t have to set the redirect URIs.

    RWM

    I am facing issue with Google Credentials login.
    I created client ID and in Authorized JavaScript origins on Google Developer console I added the main website URL.
    After that when I click on “Sign in With Google”, I get following error
    Authorization Error
    Error 400: redirect_uri_mismatch

    Can you please let me know if there is a specific login URI which should be set in the Google Credentials to support login with Google?

    ihor developer

    Please try leaving the redirect URL field empty, if you just create a new OAuth credential via the Google API Console and set the Client ID in HivePress settings it should be ok.

    umar farooq

    Hello @ihor,
    I’m having an issue with Google Login – I’ve filled my client ID etc when when I enter my Google credentials, it says “one moment…” but then takes me to an empty sign in form. I don’t have any cache plugin. A long time ago I had cheetah cache plugin. This trouble from the cache plugin?

    ihor developer

    Please make sure that the OAuth app you created via the Google API Console is set up correctly, if the Client ID is correct then it should be ok. If it just refreshes the page then it’s most likely a caching issue (caused by a plugin or some server-side caching enabled by the hosting provider).

    movedbymark

    Same issue as RWM above. I receive this error message:
    Error 400: redirect_uri_mismatch

    I did not add a redirect URL but just pasted the Client ID in HivePress settings. Any other ideas?

    movedbymark

    Ah, never mind! I had “www” included in the origin URI which appears to have been the mismatch.
    🙂

    (I don’t see a way to edit/ delete posts here)

    ihor developer

    Thanks for posting the solution!

Viewing 9 posts - 1 through 9 (of 9 total)

New Reply

This forum has been archived and is no longer accepting new posts or replies. Please join our new community forum for support & discussion.