Google Sign in is not happening

  • Author
    Posts
  • unitehearts

    the button does not show.
    pls give the settings to be entered in Google OAuth – what is the redirect etc.

    this is where i am using it.
    Thank you very much

    unitehearts

    I also have Youzer on the same site for Buddypress. After entering the details – i saw that there is an error also in that – it is not able to login to the Buddypress site using Google now.

    This is what I see.

    There has been a critical error on your website.

    Learn more about debugging in WordPress.

    Please help – I am very much interested in using your Plugin – and I think it has a lot of potential – if you guide me – I can solve this issue – or I can give you Admin access if you like.

    Thank you very much

    ihordeveloper

    Please check the browser error console (CTRL+Shift+I), there should be a detailed error from Google. If there’s a critical error with another plugin, please try disabling HivePress to check if HivePress causes this issue.

    I highly recommend using HivePress separate from BuddyPress because these are both content-heavy plugins, and BuddyPress stores its content in the same database table so it may get flooded pretty quickly.

    unitehearts

    Thank you Ihor for replying.
    I will be happy to use only Hivepress – but I am using Buddypress for some functionalities – which you can see here – http://www.unitehearts.in
    If you can guide me on how I can achieve the same with Hivepress – i will be happy to make the switch.

    I had to deactivate the Authentication plugin for a short time now – the error has disappeared.
    I hope you can guide me on how to make the settings – so that I can use the Authentication you have too.

    unitehearts

    I think I must have made a mistake in the settings with Authenticator – so please guide me.
    What is the OAuth Redirect URL i must put – where can i see the steps to do it properly.
    Thank you very much

    unitehearts

    Failed to load resource: the server responded with a status of 500 ()

    This was the OAuth Redirect url – https://unitehearts.in/?action=yz-social-login&provider=Google

    unitehearts

    Hi Ihor
    How are you doing ?
    Can you advise on how to implement the Google Sign in – what has to be done on the Google site. Thanks.

    unitehearts

    I just copied and pasted the Id – but did not go to the rest of the process below – like
    _____
    Load the Google Platform Library

    You must include the Google Platform Library on your web pages that integrate Google Sign-In.

    <script src=”https://apis.google.com/js/platform.js&#8221; async defer></script>

    Specify your app’s client ID
    _____

    Do these steps like inserting script etc need to be done too ?

    ihordeveloper

    You don’t have to insert any scripts from Google, just the client ID in HivePress/Settings/Integrations/Google section. Please make sure that you set the authorized URL in the API settings (in Google API Console) to your site URL. This tutorial may help (it also creates a client Secret, but it’s not required) https://theonetechnologies.com/blog/post/how-to-get-google-app-client-id-and-client-secret Please let me know when you enable Google Sign In again and I’ll check your site’s error console in the browser.

    letsgetdelivery

    HI can you check mines as well?

    Oddly its not working for me as well. If I use a Social Login plugin I get it to work but not using the native HivePress.

    http://www.letsgetdelivery.com

    unitehearts

    Hi Ihor
    Thank you very much for replying.
    I have activated the Authentication on https://unitehearts.in/free-ads/
    Please see.

    unitehearts

    hi Ihor
    As per the link you sent – i followed the process perfectly – just left the Authorized redirect URIs – blank and in the Authorized JavaScript origins entered – https://unitehearts.in

    Still not showing the Google on the site. Hope you find time and find the issue. Thank you very much

    ihordeveloper

    The button is still hidden (even in the code), if you set the client ID please send temporary WP access to support@hivepress.io and I’ll check this issue. You can send it without password using this plugin https://wordpress.org/plugins/temporary-login-without-password/

    ihordeveloper

    @letsgetdelivery On your site Google displays this error:

    Google Maps JavaScript API error: RefererNotAllowedMapError
    https://developers.google.com/maps/documentation/javascript/error-messages#referer-not-allowed-map-error

    Please set your site URL in the allowed referrers in the client settings.

    letsgetdelivery

    am i doing it in the right place ?
    i did this previously and it didn’t work i have now put it back in and no dice..

    Oauth settings

Viewing 15 posts - 1 through 15 (of 21 total)

You must be logged in to reply to this topic.

Subscribe

Sign In

Don't have an account? Register

Forgot password?

Register

Already have an account? Sign In

Forgot password?

Reset Password

Please enter your username or email address, you will receive a link to create a new password via email.