Free Directory, Listing & Classifieds WordPress Plugin Support General HivePress Having a bit of trouble with the listings

Having a bit of trouble with the listings

  • Author
    Posts
  • matt

    Hello Ihor! Hope you are having a great day! I installed the new update and tried setting some attributes to the ‘AND’ function i.e. checking the ‘search any of the selected options’. Now I am starting to have issues where no listings show up in the filter. I have tried to create a test listing and select the exact same values for its attributes in the filter menu and still, the listing doesn’t show up. I would appreciate any insight into the issue.

    matt

    This is the settings for the attributes for my test listing: https://prnt.sc/t6opqm, https://prnt.sc/t6oq1o
    This is the filtered results: https://prnt.sc/t6opf0

    ihordeveloper

    The “and” operator is set by default, by selecting the “Search any of the selected…” you switch it to “or”, so if you select it then it should search listings for any of the selected options (instead of listings that have all of the selected options).

    matt

    Hi Ihor, sorry I meant that I wanted the ‘OR’ operator but not to worry I have narrowed down the problem and it is completely unrelated to the AND/OR operator. It is specifically to do with filtering by number range. So my guess is there is some issue with rounding of decimals (rounding down for lower bound and rounding up for upper bound) that causes listings with values at the upper bound and lower bound to be missed in the filter results. Here is how to replicate:

    1) Set sortable, searchable number range attribute, set 4 decimals
    2) Set test listing with value 99.95 and another listing with 50.05.
    3) Clicking filter with range 50.05 – 99.95
    4) Neither listing should show up in the search results <– Problem

    Hopefully, this post makes sense.

    ihordeveloper

    Thanks for reporting this issue, it seems to be a bug. I checked it locally and it seems to include listings from the upper limit, but not from the lower one. I’ll make a quick update next week and will fix this.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Subscribe

Sign In

Don't have an account? Register

Forgot password?

Register

Already have an account? Sign In

Forgot password?

Reset Password

Please enter your username or email address, you will receive a link to create a new password via email.