Home Support Themes ExpertHive New Attributes Not Showing up in Search

New Attributes Not Showing up in Search

  • Author
    Posts
  • goodkarma

    Hey Ihor – a quick question about creating new attributes – and then having them show up in the search/filter sidebar on the listing services page. (i’m sure I’m doing something wrong here – but quick guidance would be appreciated)

    I’ve created a new Attribute (gig total – rather than hourly rate) – and have assigned it to be a filterable option – with the expectation that it would show up as an option on the services sidebar – as a fliterable option.

    It’s not – and in addition – i’ve removed the “hourly rate” as a filterable option – and yet, it continues to persist on the listings page.

    Again – i’m sure this is just a simple thing i’m getting wrong – but if you could advise – i’d appreciate!

    PS – left a comment on your Product Hunt release – good to see Hivepress getting some love on PH !

    Thanks –

    Ian

    goodkarma

    Hi Ihor – just as a quick follow up to the question above – what is the difference between “sortable” and “filterable” in the attribute settings? (I think i have a good idea of how to differentiate between the two – but just want to make sure I’m understanding how to distinguish between those two qualifiers) Thanks!

    gabetu

    @goodkarma, here is a photo representing the settings: https://ibb.co/SdGFyMV

    As far as I know, only date, number and rating fields could be set as sortable … if you look at the ListingHive demo you will see that the attribute “Pets” cannot be sortable for example.

    I hope this clarify somehow your question.

    ihor developer

    Hi Ian,

    If you deleted some attribute and it still appears on the frond-end this may be a caching issue, please try disabling the caching plugins or server-side caching (sometimes this is enabled by the hosting providers). If you publish a new attribute and mark it as filterable (and it has its Edit and Search types set) then it should appear in the filters form. The Sortable option adds this attribute as a sorting option (to the “sort by” drop-down list), but it works for number/text/date attributes only.

    Thanks for your comment on PH and for your years-long support:)

    goodkarma

    Thanks, @Gabetu – much appreciate your help!

    Thanks, Ihor – makes total sense, and yes…..was a caching issue for sure – i sorted this (no pun intended 🙂 shortly after posting the issue above, and works as expected. Much appreciated!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.