Skip Checkout for free listing

  • Author
    Posts
  • workin

    Is it possible to skip the checkout page for free listing ? it’s poor user experience and might be confusing 🙂

    Also is it possible to rename the ‘Buy Package’ Button to ‘Select’

    Thanks so much again

    workin

    oh Just realised that if I dont select WooCommerce product I get what I wanted :)!

    workin

    hmm. Testing this on incognito. Created a new user, and was adding a listing.

    When I pressed submit listing, the page just refreshed and I got nothing on the back-end.

    Tried creating another user, and same issue. It does not go in the package select nor does it submit the listing. it just refreshes. I have the latest update.

    ihordeveloper

    Please try disabling third-party plugins, I just tried to add a free package on a local installation and the packages page appears.

    Pau N

    Hi ihor, i have a similar problem, when i press select package it redirects me to the same page (or doesn’t redirect me), where it should take me or how can i configure it?

    Ex. https://cuido.cl/submit-listing/package/

    ihordeveloper

    Please make sure that WooCommerce is installed correctly, there should be the Checkout page in WordPress/Pages section (it’s imported by the WooCommerce setup wizard). Also you can re-create these pages in WooCommerce/Status/Tools section.

    Pau N

    Thanks Ihor, the Free listing package must also go in the woocommerce products then? i thought if i didn’t select a woocommerce product the user could skip the checkout page for free listing.

    ihordeveloper

    The free one should just redirect users to the “Listing Submitted” page, please make sure that you followed this screencast step by step while adding packages https://www.youtube.com/watch?v=BHRXY62FKJY

    Pau N

    Hi Ihor, i did exactly as the video but still i press the free listing and it takes me to the same “select plan” page. What could the error?

    ihordeveloper

    Please make sure that this package is not linked to a WooCommerce product. If this issue persists you can send temporary WP access to support@hivepress.io and I’ll check it.

    Pau N

    Thanks i sent you the temporary access.

    Pau N

    You will also see in the submit listing page, that there’s seems to be a problem with the date attribute (“fecha de nacimiento”) the arrows to select the date appear too big so the person can’t see the whole calendar modal.

    ihordeveloper

    Seems to be a conflict with some plugin or custom code snippet, I tried disabling plugins for a moment and the listing submission worked (there may be the same reason for the calendar issue, seems like a styling conflict because it doesn’t occur with a fresh installation of HivePress).

    Pau N

    Thanks Ihor, i tested all the plugins and it’s the Elementor plugin that’s causing the conflict with the calendar and listing submission. 🙁

    I made almost all the pages with Elementor so it’s difficult for me to just disable it, the calendar is no problem i can just put a text box for the date of birth, but the process to skip the checkout it’s essential, could there be another way to fix this?

    Pau N

    I deleted other plugins “Elementor header” and a translator plugin, and worked great without disabling Elementor. Only the calendar styling conflict but i’ll change the attribute as a text box.

    Thanks Ihor, soon we will launch the website.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.

Subscribe

Sign In

Don't have an account? Register

Forgot password?

Register

Already have an account? Sign In

Forgot password?

Reset Password

Please enter your username or email address, you will receive a link to create a new password via email.